Les Forums

Les Forums

Les forums sont fermés. Ils restent présent pour consultation et archivage.
Vous pouvez désormais poser vos questions directement dans les commentaires en bas de chaque page du site.
Alors n'hésitez pas à participer

limitation/bug with the dictionary function of EnableSecret

is there a limitation or a bug with the dictionary function?
the dictionary has 23000 lines with the matching entry. for example "cisco"

I've got a message that no password was found, but with the "-view 1" option the key is calculated.

EnableSecret -password $1$Wx4W$YXHLyWM.LhIt7V5J6neJ3/ -dictionnary 1 -file_name_dico 123.txt -view 1

Sorry, but the password was not found

But the calculated secret $1$Wx4W$YXHLyWM.LhIt7V5J6neJ3/ and the "-password $1$Wx4W$YXHLyWM.LhIt7V5J6neJ3/" are the same.

with a small dictionary with less than 300 lines the result is
Yes, the password was found. It's : cisco

Is it a bug, feature or my fault.
Has anyone suggestions to use the whole dictionary?

Best regards
Lu Jerry,

I create a dictionnary with 30000 entries and I place the word cisco at the end.

After I use your command :
EnableSecret -password $1$Wx4W$YXHLyWM.LhIt7V5J6neJ3/ -dictionnary 1 -file_name_dico 123.txt -view 1

And the exe found the good password.

Peraphs a bug, but not at home.

Peraphs a problem with your dictionnary (caracters, enter, ...)

_SebF - Sébastien FONTAINE
thanks for testing.
i had generated a new dictionary and the problem is still there.

with try & error i think i ve found the limitation.

My dictionary includes words with large entrys >50 characters
with more than 40 chars (+=41) the program crashed with an windows error.
this problem was solved before i wrote this topic. Use less than 40 character.

with more than 18 characters (+=19) the calculated key is right but the verification of the given and the calculated key does not work.
If there is an enty with more than 18 chars all following passwords will be ignored.

with less or equal 18 Chars the verification worked well.
i think thats the limitation.

I split my dictionary, first dictionary to the maximum of 18 characters per line and it worked well.
Longer passwords hardly occur. 😉

Best regards
Hi Jerry,

I tested the same command with my computer.

When I place a word with 319 characters, I obtain no error.
When I place a word with 320 characters, I obtain an windows error.

I don't have the same limit as you. (for the fun, 40*8=320:)

Else, when i place a long word in the disco, the password Cisco isn't found. Then I think is a problem with the memory and the declaration of my variables. I look that.

Thanks for your comment.

_SebF - Sébastien FONTAINE
Hi Jerry,

I found the problem. It's was the variable "TAILLE_MAX_MOT", I put the value 300.

Then now, the words in the dictionnary must be lower than 300 Bytes.

The news version is and [url=http://www.authsecu.com/enable-secret-password-cisco-brut-force/enable-secret-password-cisco-brut-force.php]you can download it here.[/url]

_SebF - Sébastien FONTAINE
thank you for fixing the limitation _sebf,

i tried the new version with my old dictionary and it worked well.
Many thanks!


A suggestion for future version is the implementation of the Cisco PIX Enable secret decryption.